What are the supported .NET framework versions?

Mar 1, 2010 at 4:19 PM

I wonder what .NET framework versions are supported? Particularly, can I build this adapter on 2.0?

(I have built a proprietary adapter very similar to yours, the main goal of which was to make System.Windows.Automation work without the buggy WPF on 2.0)

Feb 11, 2013 at 9:53 AM
Edited Feb 11, 2013 at 11:57 AM
I found out that this adapter a bit changed inside
UI Automation Verify (UIA Verify)
is build agaist 2.0
Feb 11, 2013 at 10:00 AM
I have forked this project at https://github.com/JakeGinnivan/UIAComWrapper and fixed up a few bugs/issues I have had with it.

I am trying to port White (https://github.com/TestStack/White) to run on top of this adapter, so while I don't have time to actively make fixes to this project, I am happy to manage pull requests submitted to my repo. I have also published this to NuGet and will keep publishing updates to my fork

@markhor, I would love contributions and it would be better to join forces on my fork than try and get our own going.