Using with a Real Project

Here's what I did to get UIA Verify working with the COM Wrapper.

1. Downloaded the source to UIA Verify. I had to upgrade the .NET Framework to 3.5 for all of its 5 projects. The UIAComWrapper might work with lower versions of the .NET Framework, but I haven't tried it yet.

2. Removed all references to UIAutomationClient and UIAutomationTypes and replaced with a reference to a built version of UIAComWrapper.

3. Recompiled and ran on a Windows 7 machine.

Getting another project to work with UIAComWrapper should be approximately the same steps.

Last edited Jan 3, 2010 at 8:59 PM by MSBernstein, version 1

Comments

No comments yet.